Konfigurasi Router menggunakan Routing Protocol EIGRP

Pada kesempatan yang sebelumnya saya pernah memposting artikel tentang “Konfigurasi Router menggunakan Routing Information Protocol (RIP)“. Pada kesempatan kali ini saya akan mencoba untuk memposting tentang Konfigurasi Router dengan menggunakan Routing Protocol yang berbeda sesuai dengan janji saya sebelumnya, yaitu menggunakan Enhanced Interior Gateway Routing Protocol (EIGRP). EIGRP merupakan pengembangan dari Interior Gateway Routing Protocol (IGRP) yang memiliki jumlah Maksimum hop sebanyak 255 hop, dibandingakan dengan Routing Information Protocol (RIP) yang hanya memiliki jumlah maksimum hop sebanyak 15 hop.

EIGRP biasa digunakan pada Sistem jaringan yang memiliki Network yang berskala besar. Selain itu juga, pada Router EIGRP, pada saat kita mengkonfigurasinya, kita tidak perlu memperkenalkan Network-Nework yang terhubung pada Router tetangga yang sudah tersimpan pada Routing Tablenya. Pada Router EIGRP ini, akan mencari sendiri Routing Table dari Router-Router tetangganya.

Di dalam EIGRP juga, kita mengenal yang namanya Autonomous System (AS) yang berfungsi untuk membuat semua Router yang berada pada AS yang sama berada dalam satu lingkup area sehingga dapat melakukan Komunikasi Data dari Sumber sampai ke Tujuan. Apabila masing masing Router di set dengan menggunakan AS yang berbeda, maka antara Router tersebut tidak dapat saling melakukan pertukaran data.

Dalam Router EIGRP juga mendukung yang namanya VLSM (Variable Lenght Subnet Mask) dimana mengijinkan jalur-jalur secara otomatis diringkas pada batas angka Network..Pada EIGRP juga tidak melakukan update secara periodik, tetapi akan melakukan Update apabila terjadi perubahan pada Routing Table.

Dibawah ini merupakan contoh konfigurasi Router dengan menggunakan EIGRP, desain jaringan beserta IP yang digunakan pada pembahasan kali ini sengaja saya buat sama dengan desain jaringan pada artikel saya sebelumnya yang berjudul “Konfigurasi Router Menggunakan Protokol Routing Information Protocol (RIP)“. Tujuan saya agar kawan-kawan pembaca sekalian dapat membandingkan konfigurasi antara kedua Routing Protocol ini, berikut adalah desain dan konfigurasi menggunakan Routing Protocol EIGRP :

 

Desain router RIP dan EIGRP

Desain router RIP dan EIGRP

 

LAN A :
IP 20.20.20.2
Subnet Mask 255.0.0.0
Gateway 20.20.20.1

LAN B :
IP 198.100.100.2
Subnet Mask 255.255.255.0
Gateway 198.100.100.1

LAN C :
IP 150.140.140.2
Subnet Mask 255.255.0.0
Gateway 150.140.140.1

LAN D :
IP 135.135.135.2
Subnet Mask 255.255.0.0
Gateway 135.135.135.1

ROUTER 1 :
fast ethernet 0/0 : 20.20.20.1
serial 0/0/0 :140.140.140.1
serial 0/0/1 : 200.200.200.1

ROUTER 2 :
fast ethernet 0/0 : 198.100.100.1
serial 0/0/0 :140.140.140.2
serial 0/0/1 : 10.10.10.1

ROUTER 3 :
fast ethernet 0/0 : 150.140.140.1
serial 0/0/0 :10.10.10.2
serial 0/0/1 : 7.7.7.1

ROUTER 4 :
fast ethernet 0/0 : 135.135.135.1
serial 0/0/0 :200.200.200.2
serial 0/0/1 : 7.7.7.2

Konfigurasinya adalah sebagai berikut :

ROUTER 1 :

router# configure terminal
router(config)#hostname router1
router1(config)#interface fastethernet0/0
router1(config-if)#ip address 20.20.20.1 255.0.0.0
router1(config-if)#no shutdown
router1(config-if)#exit
router1(config)#interface serial0/0/0
router1(config-if)#ip address 140.140.140.1 255.255.0.0
router1(config-if)#no shutdown
router1(config-if)#exit
router1(config)#interface serial0/0/1
router1(config-if)#ip address 200.200.200.1 255.255.255.0
router1(config-if)#clock rate 64000
router1(config-if)#no shutdown
router1(config-if)#exit
router1(config)#router eigrp 10
router1(config-router)#network 20.0.0.0
router1(config-router)#network 140.140.0.0
router1(config-router)#network 200.200.200.0
router1(config-router)#exit
router1(config)#exit

ROUTER 2 :

router# configure terminal
router(config)#hostname router2
router2(config)#interface fastethernet0/0
router2(config-if)#ip address 198.100.100.1 255.255.255.0
router2(config-if)#no shutdown
router2(config-if)#exit
router2(config)#interface serial0/0/0
router2(config-if)#ip address 140.140.140.2 255.255.0.0
router2(config-if)#no shutdown
router2(config-if)#exit
router2(config)#interface serial0/0/1
router2(config-if)#ip address 10.10.10.1 255.0.0.0
router2(config-if)#clock rate 64000
router2(config-if)#no shutdown
router2(config-if)#exit
router2(config)#router eigrp 10
router2(config-router)#network 198.100.100.0
router2(config-router)#network 140.140.0.0
router2(config-router)#network 10.0.0.0
router2(config-router)#exit
router2(config)#exit

ROUTER 3 :

router# configure terminal
router(config)#hostname router3
router3(config)#interface fastethernet0/0
router3(config-if)#ip address 150.140.140.1 255.255.0.0
router3(config-if)#no shutdown
router3(config-if)#exit
router3(config)#interface serial0/0/0
router3(config-if)#ip address 10.10.10.2 255.0.0.0
router3(config-if)#no shutdown
router3(config-if)#exit
router3(config)#interface serial0/0/1
router3(config-if)#ip address 7.7.7.1 255.0.0.0
router3(config-if)#clock rate 64000
router3(config-if)#no shutdown
router3(config-if)#exit
router3(config)#router eigrp 10
router3(config-router)#network 150.140.0.0
router3(config-router)#network 10.0.0.0
router3(config-router)#network 7.0.0.0
router3(config-router)#exit
router3(config)#exit

ROUTER 4 :

router# configure terminal
router(config)#hostname router4
router4(config)#interface fastethernet0/0
router4(config-if)#ip address 135.135.135.1 255.255.0.0
router4(config-if)#no shutdown
router4(config-if)#exit
router4(config)#interface serial0/0/0
router4(config-if)#ip address 200.200.200.2 255.255.255.0
router4(config-if)#no shutdown
router4(config-if)#exit
router4(config)#interface serial0/0/1
router4(config-if)#ip address 7.7.7.2 255.0.0.0
router4(config-if)#clock rate 64000
router4(config-if)#no shutdown
router4(config-if)#exit
router4(config)#router eigrp 10
router4(config-router)#network 135.135.0.0
router4(config-router)#network 200.200.200.0
router4(config-router)#network 7.0.0.0
router4(config-router)#exit
router4(config)#exit

Diatas tadi merupakan konfigurasi dari Router yang menggunakan Routing Protocol EIGRP. Kita dapat melihat diatas, bahwa masing-masing Router memiliki Autonomous System (AS) yang sama, yaitu 10. Yang menandakan bahwa Router-Router tersebut berada dalam satu lingkup yang sama. Apabila kita membandingkan dengan konfigurasi menggunakan Routing Information Protocol (RIP), pada EIGRP ini, kita tidak perlu menuliskan lagi Network-Network yang terhubung pada Router-Router tetangga, karena pada EIGRP ini, akan mencari sendiri Routing Table dari Router tetangganya. Selain itu juga EIGRP dapat mengatasi masalah pada RIP dalam hal keterbatasan jumlah hop maksimum yang dimiliki oleh RIP.

Mungkin untuk sementara itu saja yang bisa saya berikan pada kesempatan kali ini, mudah-mudahan dapat menambah Referensi dari kawan-kawan pembaca sekalian….

Kata bijak Hari ini “Atasilah satu kesulitan, maka anda akan terhindar dari kesulitan yang lain. Jangan dulu mengatakan TIDAK BISA jika anda belum MENCOBA, PROSES anda dalam menjadi BISA yang akan menentukan. Jadi tetap semangat..dan Yakin Usaha Sampai.

SumberĀ  : http://herman-it.blogspot.com/2009/09/konfigurasi-router-menggunakan-routing.html

About the author

Pantang tolak tugas, Pantang tugas tak terselesaikan , Pantang Ulur Waktu dan Yakin Usaha Sampai . . . . . .