Konfigurasi Router Mengunakan Protokol Routing Information Protocol (RIP)

Pada kesempatan yang lalu, saya telah memposting tentang pengenalan terhadap ROUTER, saya yakin kawan-kawan pembaca telah dapat memahami apa fungsi utama dari router tersebut. Sekarang pada kesempatan kali ini saya akan mencoba untuk mengulas sedikit tentang konfigurasi router menggunakan Protokol Routing Information Protocol (RIP).

Seperti yang saya bahas pada artikel tentang ROUTER yang lalu, bahwa ada beberapa macam jenis Routing Protocol, Antara lain: RIP, IGRP, EIGRP, OSPF dll. Dari masing – masing Routing Protocol tersebut memiliki konfigurasi yang agak berbeda. Jika ada waktu, setelah menyelesaikan Konfigurasi Router menggunakan Protocol Routing Information Protocol (RIP) ini, saya akan mencoba untuk membagi tentang bagaimana cara untuk mengkonfigurasi Router menggunakan Routing Protocol yang lain….Insya Allah…..

Adapun kasus desain dari jaringan yang akan kita konfigurasi adalah seperti pada gambar dibawah ini:

Seperti yang bisa kita lihat pada gambar di atas, bahwa terdapat 8 Network Address yang berbeda, mulai dari Kelas A, B dan C. yang artinya bahwa untuk dapat berkomunikasi antara LAN pada desain jaringan di atas, hanya dapat dilakukan dengan menggunakan media penghubung yang dinamakan ROUTER. yang perlu kita perhatikan pada Konfigurasi ini, kita harus menggambar Pemetaan Jaringan yang akan kita desain beserta NETWORK dan IP pada masing – masing host untuk menghidari kemungkinan kesalahan pada saat Konfigurasi nanti. Berikut merupakan daftar IP secara lengkap dari gambar rangkaian di atas, yaitu :

LAN A :
IP 20.20.20.2
Subnet Mask 255.0.0.0
Gateway 20.20.20.1

LAN B :
IP 198.100.100.2
Subnet Mask 255.255.255.0
Gateway 198.100.100.1

LAN C :
IP 150.140.140.2
Subnet Mask 255.255.0.0
Gateway 150.140.140.1

LAN D :
IP 135.135.135.2
Subnet Mask 255.255.0.0
Gateway 135.135.135.1

ROUTER 1 :
fast ethernet 0/0 : 20.20.20.1
serial 0/0/0 :140.140.140.1
serial 0/0/1 : 200.200.200.1

ROUTER 2 :
fast ethernet 0/0 : 198.100.100.1
serial 0/0/0 :140.140.140.2
serial 0/0/1 : 10.10.10.1

ROUTER 3 :
fast ethernet 0/0 : 150.140.140.1
serial 0/0/0 :10.10.10.2
serial 0/0/1 : 7.7.7.1

ROUTER 4 :
fast ethernet 0/0 : 135.135.135.1
serial 0/0/0 :200.200.200.2
serial 0/0/1 : 7.7.7.2

Di atas tadi merupakan IP yang akan digunakan dalam konfigurasi sesuai dengan Network Address yang telah ditentukan pada gambar di atas. Untuk diketahui bahwa Protocol RIP ini merupakan jenis Routing Protocol Distance Vektor, dimana akan mengirimkan paket dari Sumber ke Tujuan berdasarkan jumlah Hop atau loncatan paling sedikit. RIP sendiri mempunyai keterbatasana Hop yang akan dilalui oleh sebuah paket, yaitu sebanyak 15 Hop yang diijinkan, jadi apabila sampai 16 kali Hop, maka Paket tersebut tidak dapat diteruskan ke tujuannya. Berdasarkan uraian tadi, dapat disimpulkan bahwa Yang kita akan konfigurasi ini yaitu merupakan router Dynamic, dimana router akan menentukan jalurnya sendiri untuk mengirimkan paket sampai ke tujuan.Setelah uraian yang saya paparkan tadi diatas, maka sekarang waktunya kita mengkonfigurasi router dengan menggunakan PC Console yang kita gunakan khusus untuk mengkonfigurasi router menggunaka hyper terminal. Berikut konfigurasi dari masing-masing router :

ROUTER 1 :

router# configure terminal
router(config)#hostname router1
router1(config)#interface fastethernet0/0
router1(config-if)#ip address 20.20.20.1 255.0.0.0
router1(config-if)#no shutdown
router1(config-if)#exit
router1(config)#interface serial0/0/0
router1(config-if)#ip address 140.140.140.1 255.255.0.0
router1(config-if)#no shutdown
router1(config-if)#exit
router1(config)#interface serial0/0/1
router1(config-if)#ip address 200.200.200.1 255.255.255.0
router1(config-if)#clock rate 64000
router1(config-if)#no shutdown
router1(config-if)#exit
router1(config)#router rip
router1(config-router)#network 20.0.0.0
router1(config-router)#network 140.140.0.0
router1(config-router)#network 200.200.200.0
router1(config-router)#exit
router1(config)#ip host router2 198.100.100.1 140.140.140.2 10.10.10.1
router1(config)#ip host router3 150.140.140.1 10.10.10.2 7.7.7.1
router1(config)#ip host router4 135.135.135.1 200.200.200.2 7.7.7.2
router1(config)#exit

ROUTER 2 :

router# configure terminal
router(config)#hostname router2
router2(config)#interface fastethernet0/0
router2(config-if)#ip address 198.100.100.1 255.255.255.0
router2(config-if)#no shutdown
router2(config-if)#exit
router2(config)#interface serial0/0/0
router2(config-if)#ip address 140.140.140.2 255.255.0.0
router2(config-if)#no shutdown
router2(config-if)#exit
router2(config)#interface serial0/0/1
router2(config-if)#ip address 10.10.10.1 255.0.0.0
router2(config-if)#clock rate 64000
router2(config-if)#no shutdown
router2(config-if)#exit
router2(config)#router rip
router2(config-router)#network 198.100.100.0
router2(config-router)#network 140.140.0.0
router2(config-router)#network 10.0.0.0
router2(config-router)#exit
router2(config)#ip host router1 20.20.20.1 140.140.140.1 200.200.200.1
router2(config)#ip host router3 150.140.140.1 10.10.10.2 7.7.7.1
router2(config)#ip host router4 135.135.135.1 200.200.200.2 7.7.7.2
router2(config)#exit

ROUTER 3 :

router# configure terminal
router(config)#hostname router3
router3(config)#interface fastethernet0/0
router3(config-if)#ip address 150.140.140.1 255.255.0.0
router3(config-if)#no shutdown
router3(config-if)#exit
router3(config)#interface serial0/0/0
router3(config-if)#ip address 10.10.10.2 255.0.0.0
router3(config-if)#no shutdown
router3(config-if)#exit
router3(config)#interface serial0/0/1
router3(config-if)#ip address 7.7.7.1 255.0.0.0
router3(config-if)#clock rate 64000
router3(config-if)#no shutdown
router3(config-if)#exit
router3(config)#router rip
router3(config-router)#network 150.140.0.0
router3(config-router)#network 10.0.0.0
router3(config-router)#network 7.0.0.0
router3(config-router)#exit
router3(config)#ip host router1 20.20.20.1 140.140.140.1 200.200.200.1
router3(config)#ip host router2 198.100.100.1 140.140.140.2 10.10.10.1
router3(config)#ip host router4 135.135.135.1 200.200.200.2 7.7.7.2
router3(config)#exit

ROUTER 4 :

router# configure terminal
router(config)#hostname router4
router4(config)#interface fastethernet0/0
router4(config-if)#ip address 135.135.135.1 255.255.0.0
router4(config-if)#no shutdown
router4(config-if)#exit
router4(config)#interface serial0/0/0
router4(config-if)#ip address 200.200.200.2 255.255.255.0
router4(config-if)#no shutdown
router4(config-if)#exit
router4(config)#interface serial0/0/1
router4(config-if)#ip address 7.7.7.2 255.0.0.0
router4(config-if)#clock rate 64000
router4(config-if)#no shutdown
router4(config-if)#exit
router4(config)#router rip
router4(config-router)#network 135.135.0.0
router4(config-router)#network 200.200.200.0
router4(config-router)#network 7.0.0.0
router4(config-router)#exit
router4(config)#ip host router1 20.20.20.1 140.140.140.1 200.200.200.1
router4(config)#ip host router2 198.100.100.1 140.140.140.2 10.10.10.1
router4(config)#ip host router3 150.140.140.1 10.10.10.2 7.7.7.1
router4(config)#exit

Ya…ternyata lumayan juga nih kalau kita mengkonfigurasi 4 buah router…hehehe…so…kita harus teliti, terutama untuk IP, dan kita pun harus paham mengenai IP itu sendiri..Insya Allah dilain kesempatan, saya juga akan mencoba membahas tentang IP….Mudah-mudahan artikel ini bisa menambah referensi dan membatu kawan-kawan pembaca sekalian…mungkin hanya ini yang dapat saya tulis pada kesempatan kali iniKata Bijak Hari ini:”Kita tahu bahwa kita harus menyelesaikan sesuatu, kita tahu bahwa apabila kita tidak menyelesaikannya maka akan berakibat masalah yang sangat besar bagi kita, dan kita tahu bahwa kita belum mengerjakannya..jadi PANTANG ulur waktu kawan”

Semoga bermanfaat…Good Luck untuk semua & Yakin Usaha Sampai……..

SumberĀ  : http://herman-it.blogspot.com/2009/08/konfigurasi-router-menggunakan-protokol.html

About the author

Pantang tolak tugas, Pantang tugas tak terselesaikan , Pantang Ulur Waktu dan Yakin Usaha Sampai . . . . . .